[a / b / c / d / e / f / g / gif / h / hr / k / m / o / p / r / s / t / u / v / vg / vr / w / wg] [i / ic] [r9k] [s4s] [cm / hm / lgbt / y] [3 / aco / adv / an / asp / biz / cgl / ck / co / diy / fa / fit / gd / hc / his / int / jp / lit / mlp / mu / n / news / out / po / pol / sci / soc / sp / tg / toy / trv / tv / vp / wsg / wsr / x] [Settings] [Home]
Board
Settings Home
/3/ - 3DCG

[Advertise on 4chan]


Thread archived.
You cannot reply anymore.



File: luxrender.jpg (19 KB, 740x233)
19 KB
19 KB JPG
What does /3/ think about the recent advancements Luxrender has made in the last couple of years?

Also renderers general I guess.
>>
Lux is great
>>
Lux is good
>>
Lux is alright
>>
It's great that it exists, just like Blender. And it's cool to see these types of projects will go in comparison to commercial renderers.

But I heard speed is still an issue, and most renderers are quite specialist tools. It means you kind of have to invest some time into learning them, I'd rather learn a tool that wouldn't slow me down in the future, and a Vray license is just 750 bucks away (not that much).
>>
Trying to install it for a week.
And every fuckin time my blender just explodes without any kind of crash report or log.
I just turn it on, play with nodes, amaze about its cool features. AND LIKE A FUCKING DAVID COPPERFIELD THAT SHIT JUST DISAPPEARS.
I even reinstalled Windows. SUKABLAD!!
So what do I think about "luxrender"?
I will rather gonna fuck myself with the real blender and turn my ass into a bloody shitty soup than mess with that crap one more time!

P.s.: in math node there's "clamp" function. Is there any way to do similar in cycles?
>>
>>510836
Maybe your computer is or you are shit? I've installed luxrender multiple times on different computers without a hitch. The only time I've had it crash on me (only one or two scenes did this) was when it does external rendering on the lux app but when run it again it works, probably a nasty bug, however when using internal it never crashes.

Also yes there is I think it's also called clamp.
>>
>>510836
I literally tried to mimic the Cycles nodes with the math nodes as I implemented them... of course there's a similar clamp function in the Cycles math nodes.
>>
>>510817
>But I heard speed is still an issue
Since when? With Luxcore it has made great improvement in speeds. Definitely not as fast as more supported renderers but loads faster than what it used to be.
>>
File: clampshit-screenshot.png (24 KB, 402x243)
24 KB
24 KB PNG
>>510836
>>510856
Here, just for you:
Add via "Shift+A -> Color & Math -> Math"
>>
File: clampshit_cycles.png (58 KB, 498x596)
58 KB
58 KB PNG
>>510860
Crap, I'm drunk. This is the Cycles version:
>>
>>510861
Actually i'm trying to make procedural landscape colouring. So i separate z position of geometry.
And then i need to turn this array into another ranged between 0 and 1. With "0" at minimum point and "1" at maximum. So the "Clamp" node is great for this action. But in "cycles"
I just dont know what to do.
>>
File: mounttex.png (281 KB, 1237x624)
281 KB
281 KB PNG
>>510912
I tried as hard as I could
>>
File: 2354654654.jpg (21 KB, 337x294)
21 KB
21 KB JPG
>>510836
>One software doesn't work
>Reinstall all of windows
>>
>>511459
And you'[re trying to do this in Luxrender, right? From my small time in Luxrender using procedural textures is a bit of a bitch. Most of the textres in Lux are either, A. float textures only, or B, not supported in classic API. There are clamp nodes in Luxrender now but they are only available for the Luxcore API which in its current state is still unstable at times.

For most stuff I've just resorted to using (and making if I have to) textures for just about everything in Luxrender. And if I'm right your filename implies that you are trying to make a mountain. Just download L3DT. It is a landscape generator (albeit nowhere near as good as World Machine) that has a free downgraded version. If I remember correctly the paid version is pretty cheap.
>>
>>511497
I see this come up so often when googling software specific problems i can't solve.
it blows my mind that anybody would jump to the conclusion that it is the OS with a problem over say, hardware.
>>
>>511497
Nope, I reinstalled it cause Windows 10 is piece of crap. So I was full of hope that I can possibly try it on new fresh OS. But without any reason that shit happened. Again.
>>
>>511699
because it's not the Fucking OS you idiot.
>without any reason
Clearly there's a reason or it would work

>BlendTards
>>
>>511699
>implying win10 is not currently the best windows
>>
>>511699
New Russians, everyone
>>
>>511699
You know this is what they have support forums for.
>>
File: 1453496451932.gif (56 KB, 640x400)
56 KB
56 KB GIF
>>512544
>>
>>511522
because software conflicts are the number one reason shit breaks. depending on how much you have installed, its easy to reinstall the os and make damn sure everything is fresh then it would be to buy new hardware only to see its still fucking doing that shit.

i use to have an issue where out of nowhere the sound of opening of folder would happen, and it happened across formats, it wasn't until my motherboard died and i got a new computer that it stopped, and i still to this day have no fucking clue what caused this shit to happen, it was the most maddening bug i ever dealt with because there were no errors, there were no failures, it just made a folder opening sound every so often.



[Advertise on 4chan]

Delete Post: [File Only] Style:
[Disable Mobile View / Use Desktop Site]

[Enable Mobile View / Use Mobile Site]

All trademarks and copyrights on this page are owned by their respective parties. Images uploaded are the responsibility of the Poster. Comments are owned by the Poster.